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Purpose
This manual provides a quick reference for user of the Augment Automotive 3D Tuner
application.

Scope
It is broadly relevant to all versions of 3D Tuner. Not all features are available in all versions of
3D Tuner. For advice on a specific version of 3D Tuner contact Augment Automotive.
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Starting the Augment Automotive 3D Tuner
Double click the executable file “Augment Automotive 3D Tuner.exe” to start the application.
Select the screen resolution, graphics quality and whether the application should run in a
window. If the application runs slowly reduce the resolution and or graphics quality to suit your
computer. Press “Play” to start the tuning application.
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Connecting to the AugTronic ECU
Obtain a COM port as per the “Augment Automotive Serial Connection Manual”. Once your
COM port has been obtained you can connect to the AugTronic system. Click on the
“Communications” menu button then the “Select COM Port” menu button and then select the
correct COM port from the list.

On successful connection an ECU connected message will pop up asking if you want to load
the settings from the AugTronic ECU or to keep current settings. If current settings are kept the
computer will not sync with the ECU unless you click “Communications” then “Set ECU Ram”. If
the settings on the ECU are adopted the configuration will be automatically loaded and the ECU
synced with the computer. Changes can only be made if tuning mode is enabled. To check click
the mode button and ensure that tuning mode is enabled. If the 3D tuner application is not
correct for the AugTronic firmware version an error will raise. Contact Augment Automotive for
advice if this is the case.
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Grid Selection
In the Augment Automotive 3D tuner the maps on the AugTronic ECU are represented as grids
aka maps that can be selected by left clicking on the “Grid Selection” or on some versions “Map
Selection” menu button:

See the Hotkey section for controls used in manipulation of the grids as part of the tuning
process. In general the grid points are manipulated by selecting a single point by left clicking or
by holding the left mouse button and dragging over a group of points and releasing the left
mouse button. The point values can then be altered by pressing or holding the up or down
arrows. Grid point labels can be displayed only on the selected points or on all points by
toggling the “Label all points” option in the “Options” menu. The position of the grid sites can be
adjusted in “Grid Manipulation Mode” which can be selected under the “Mode” menu
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ECU Variables
Various ECU configuration parameters are available through left clicking on “View” then “ECU
Variables”. To edit a value enter it in the corresponding text box and hit the set button. The
variables available is specific to the version of firmware. Contact Augment Automotive Limited
for the ECU Variable description for your firmware version.
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Viewing ECU Parameters and Setting Alarms
Augment Automotive 3D tuner uses configurable dials to display ECU parameters such as
Engine Speed and Temperature. Left click on the “View” menu button and left click the add dial
to add a draggable dial to the view. The dial can be dragged via the top bar.

Left click the “Set Dial” button to get a scrollable list of parameters, then left the desired
parameter to set the dial. This dial will now display the current live value of that parameter. All
parameters can be alarmed on low and or high level. Click the “Set Alarm” button to open the
alarm menu. To change the alarm levels edit the text value and then hit the set button, the
default values are the maximum and minimum possible alarm values. Alarms can be enabled or
disabled, if the disabled button is showing the alarm is not active. Click the disabled button and
the alarm will be enabled and the button will display enabled in green text. The set alarm text
will also turn green to indicate the alarm is active. Should the alarm levels be breached an alarm
will sound and the screen flash red.
From version 1.27 of 3D tuner a summary windows is made available. This can be activated
through the view menu and clicking the “ECU Summary” button.
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Saving ECU Memory
Changes made to the ECU configuration in live mode are not permanent. In order to save
changes in the ECU the “Communications” menu button must be left clicked followed by left
click on the “Set EEPROM” button. If modifications are made to the configuration and the ECU
is reset the changes will be reverted on the ECU. On reconnection the software may attempt to
load the previous configuration from the ECU and if accepted by the user the changes may be
lost. If this happens save the configuration to laptop and load it on reconnection to the ECU.
Once EEPROM saving is complete the activity indication in the top right will flash (usually
immediately unless lots of changes have been made).
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Saving and Loading ECU Configurations
ECU configurations can be loaded from and saved to the tuning device i.e. laptop. This is done
through the “File” menu. Left click on the “File” menu button and select “Save” or “Load to gain
access to the “Save” and “Load” functions. When saving enter the file name in the text box or
click on an existing file then hit the save button. If the file exists it will not be overwritten but the
name appended with a number that generates a unique name. When loading left click a file from
the scrollable list of files and clock load. Close the load or save window by clicking on the X in
the bottom right. The window can be dragged via the top bar to an appropriate position on
screen.
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Orthographic View
To help located the engine on a particular site during tuning an orthographic view is provided. It
can be enabled through the “View” menu. The window can be dragged via the top bar to an
appropriate position on screen.
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Hotkeys

Key

Function

I

Zoom in

O

Zoom out

L

Lock selected grid site for editing

U

Unlock selected grid site for editing

Left Mouse

Select point

Right Mouse

Rotate grid

Middle Mouse/Tab

Pan grid

M

Increase size of grid site labels

N

Decrease size of grid site labels

Press Up Arrow

Increase value of grid site by one increment

Press Down Arrow

Decrease value of selected grid site by one increment

Hold Up Arrow

Increase value of selected grid by 3% per second

Hold Down Arrow

Decrease value of selected grid 3% per second

Left Shift

Hold to force change in value of point of 40% of range per
second while up or down error is held

C

Bring up command terminal. 3D grids only.
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Command terminal
As of 3D Tuner version 1.27 a command terminal can be brought up by pressing ‘c’. This
feature is only active on 3D maps. This can be used to set and manipulate the values of single
or multiple data points on the maps. The command terminal accepts a number of command
value inputs e.g. =100 would set all selected points to a value 100. The following commands are
available:

Command

Value

Description

+

decimal e.g. 10.1

add the value to the selected data point(s) existing
value(s)



decimal e.g. 10.1

subtract the value from the selected data point(s)
existing value(s)

*

decimal e.g. 10.1

multiply the selected data point(s) existing value(s)
by the value

=

decimal e.g. 10.1

set the existing data point(s) value(s) to the value

/

decimal e.g. 10.1

divide the selected data point(s) existing value(s)
by the value

l (lower case L)

none

set the value(s) of the data point(s) selected to the
value left of it

d (lower case D)

none

set the value(s) of the data point(s) selected to the
value below it

i (lower case I)

none

interpolate the value(s) of the data point(s)
selected
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ECU Variable Descriptions
AugTronic Firmware 1.08

Name

Description

Teeth per revolution

The number of teeth counted in one revolution of the flywheel

Stroke tooth set on reference
pulse

The internal stroke counter value set when the reference pulse is
seen

Rotation tooth set on reference
pulse

The internal rotation tooth set when the reference pulse is seen

Cylinder banks

The number of cylinder banks (pairs) e.g. for a 4 cylinder there are
2

Cylinder bank offsets (13)

The offset of each cylinder bank in teeth/16 this allows for correction
of errors due to alignment of the top dead position for the bank with
a tooth edge

Cylinder TDC tooth (13)

The TDC (TD really) tooth for each cylinder bank specifies at what
point in the rotation of the engine the cylinder bank reaches its top
dead position

MAP Sample Tooth

The stroke tooth on which the MAP is measured

Wasted spark enabled

Enables/disables wasted spark

Engine coasting fuel cut enabled

Enables/disables fuel cut on the overrun

Engine coasting RPM limit

Determines the RPM below which fuel cut is disabled

EGT Source

The ADC channel which EGT is being measured on

MAP sensor min value

The minimum value of the MAP sensor e.g. 200 mBar

MAP sensor max value

The maximum value of the MAP sensors e.g. 4000 mBar

MAP sensor min offset

The ADC offset of the minimum MAP sensor value e.g. for 0.4V the
value is 0.4 / (5/1023) = 82

MAP sensor max offset

The ADC offset of the maximum MAP sensor value e.g. for 4.8V the
value is 4.8 / (5/1023) = 982

MAP variability averaging limit

The minimum value in mBar above which the change in MAP
between two successive samples will disable MAP averaging

MAP averaging samples

The number of averaging samples for the MAP signal

MAP sample weight gain

When averaging the error between successive MAP samples is
divided by the weight gain and the result is used to weight the latest
MAP sample

The RPM threshold above which the engine speed is averaged for
Engine speed averaging threshold stability
Augment Automotive Limited  3D Tuner Manual  003

Page 12 of 15

Engine speed weight gain

When averaging the error between successive RPM samples is
divided by the weight gain and the result is used to weight the latest
RPM sample

Cranking RPM threshold

The RPM value above which the ECU switches from cranking to
normal running parameters

Cranking dwell teeth

The number of flywheel teeth that the ignition is in dwell during
cranking

Cranking fuel cut rotations

During cranking the fuel is cut after the specified number of
rotations to prevent flooding

Cranking idle valve duty

The idle valve duty when cranking, this is not a % duty but a raw
value from 0180. 180 would be 100% pulse width

Injector pulses per cycle

The number of times the injectors are batch fired per engine cycle
(2 rotations)

Rev limit

The RPM above which the fuel cut is activated

Rev limit hysteresis

The RPM below the rev limit at which fuel is reenabled following a
cut

Rev limit limp mode RPM

The rev limit if the ECU is in limp mode due to position sensor faults

Idle target RPM

The target idle speed

Idle ignition advance

Used to set the base ignition advance in certain idle ignition control
modes

Idle ignition advance mode

0  Use the Ignition Map, 1  Ignition set to Idle Ignition Advance, 2 
Closed loop control of ignition advance

Ignition damping enabled

Used to enable/disable smoothing of the ignition to try and reduce
engine oscillations

Ignition damping clamp

The maximum value that the damped ignition can differ from the
compensated ignition advance

PWM integral gain

The integral gain setting for the PWM idle valve control system. The
speed error is divided by this value and the result is added to the
integral summator.

PWM max integral gain

The maximum value of the integral gain

PWM integral frequency

The frequency at which the PWM closed loop algorithm executes.
This is a value for an 87hz counter so a value of 9 would cause the
loop to run approx every 0.1 seconds

Wideband min value

The minimum value output by the wideband sensor multiplied by
100 e.g. 850 for (8.5:1 AFR)

Wideband max value

The maximum value output by the wideband sensor multiplied by
100 e.g. 1800 for (18:1 AFR)

Wideband min offset

The minimum voltage offset in bits (255 is 5V) e.g. for 0.5V value =
0.5 / (5 / 255) = 25
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Wideband max offset

The maximum voltage offset in bits (255 is 5V) e.g. for 4.5V value =
4.5 / (5 / 255) = 230

Closed loop fueling enabled

Enables/disables closed loop fueling

Closed loop fueling coarse
adjustment

The value in percent that the closed loop fuel is adjusted for larger
errors

AFR sample frequency

The frequency at which the AFR is sample and the closed loop
fueling algorithm executes. This is a value for an 87hz counter so a
value of 9 would cause the loop to run approx every 0.1 seconds

Closed loop max correction

The maximum correction that can be applied in closed loop

Closed loop MAP ROC Limit

The limit above/below which closed loop is disabled for MAP rate of
change

Closed loop accel limit

The limit above/below which closed loop is disabled for engine
speed rate of change

TPS closed ADC

The TPS raw value for the throttle closed position e.g. for 0.4V the
value is 0.4 / (5/1023) = 82

TPS open ADC

The TPS raw value for the throttle open position e.g. for 4.8V the
value is 4.8 / (5/1023) = 982

Transient fuel pooling percentage

The amount of fuel in percent of base fuel time that is assumed to
be pooled e.g. on the internal surfaces of the manifold etc

Transient fuel recover percentage

The rate at which the fuel pool size corrects itself during transient
periods in percentage of the difference between the current pool
value and the new one

Transient fuel dead band

The dead band around the transient fuel in injector ticks

Boost solenoid MAP trigger

The MAP value above which the boost solenoid is enabled

Boost solenoid TPS control
enabled

Enables/disables scaling of the boost solenoid pulse width by TPS
value

Boost solenoid TPS trigger

The TPS value which is used to scale the boost solenoid pulse
width from e.g. 600 would scale the boost solenoid duty from 0 to
Max linearly from 600 to the TPS open ADC value

Debug

Not for end user use

testValue

1 = Test Fuel Pump, 2 = Test boost solenoid
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